Agrega por teclado las dimensiones de un vector

隆Haz clic para puntuar este proyecto!
(Votos: 6 Promedio: 3.3)

Pedir por teclado el tama帽o de un arreglo de n煤meros y pedir los valores num茅ricos con los que se rellena. Los valores no se pueden repetir, por lo tanto, deber谩 de encargarse de buscar cada n煤mero que lea y verificar que no se haya le铆do antes. Mostrar el arreglo con los valores al final.

驴En que programa quieres ver el C贸digo? :

    PSeInt - FLEXIBLE

    Algoritmo www_PSeInt_Site
        Escribir "TAMA脩O DEL VECTOR : "
        Leer N
        Dimension vector[N]
        Para f = 1 Hasta N Con Paso 1 Hacer
            Escribir Sin Saltar "VALOR ",f,"/",n, " : "
            Leer vector[f]		
            i = 1;
            Mientras (f > 1 Y i != f) Hacer
                Si (vector[i] == vector[f]) Entonces
                    Escribir "VALOR REPETIDO"
                    i = f - 1
                    f = f - 1
                SiNo
                    i = i + 1
                FinSi			
            FinMientras				
        FinPara
        Escribir ""
        Para f = 1 Hasta N Con Paso 1 Hacer
            Escribir Sin Saltar vector[f], "  "
        FinPara
        Escribir ""
    FinAlgoritmo
    

    Deja una respuesta

    Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *

    Subir