Ordenar un vector de menor a mayor

隆Haz clic para puntuar este proyecto!
(Votos: 6 Promedio: 4.2)

Hacer un programa que permita ingresar 10 n煤meros y mientras se valla ingresando estos sean ordenados dentro de un vector de 10 elementos.

驴En que programa quieres ver el C贸digo? :

    PSEINT ESTRICTO

    Algoritmo www_cisco_cursos_com	
        Definir fila, f, ff, vector, temp como numero;
        Dimension vector[10];		
        temp <-0;
        f <- 0;
        ff <- 0;
        // Ordena el array de forma Ascendente
        // cada que se ingrese un n煤mero.
        Para fila <- 0 Hasta 9 Con Paso 1 Hacer				
            Escribir "Ingrese N煤mero ", fila + 1, " : ";	
            Leer vector(fila);
            Para f <- 0 Hasta fila Con Paso 1 Hacer				
                Para ff <- f Hasta fila Con Paso 1 Hacer				
                    Si vector(f) > vector(ff) Entonces
                        temp <- vector(f);
                        vector(f) <- vector(ff);
                        vector(ff) <- temp;
                    FinSi				
                FinPara
            FinPara				
        FinPara	
        // Lista ordenada de forma Ascendente
        Para fila <- 0 Hasta 9 Con Paso 1 Hacer	
            Escribir vector(fila);
        FinPara
    FinAlgoritmo
    

    Deja una respuesta

    Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *

    Subir